WWW dns and rule not working, how to fix it?

So i have a domain porkbun and going through CF, its linked to https://www.switchy.io/ for creating quick URLs

http works fine but www does not, there is no hosting attached to this domain


I also configured a page rule when the above didnt work


But its still not working, i get ERR_SSL_PROTOCOL_ERROR

I use switchy to make the links and typically ill get something such as this


Your origin server probably isn’t configured to know about the www name, so it refuses to answer to that name. I have no idea what “switchy” is so I can’t provide any insight into setting that up.

Your page rule, though, should work if you enable the :orange: proxy for the www DNS entry.

1 Like

So its working kind of
https://shostel.org/I_Rw goes to the right redirected page
But www.shostel.org/I_Rw does not

If you want to forward with the path, you need the destination to be http://shostel.org/$1 (or better https://shostel.org/$1 to do the HTTPS redirect at the same time)


Great, that looks to be working

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.