Www and non-www mapping issue

I have multiple domains in Cloudflare but ONE of them has an issue: porchester.dog works fine but www.porchester.dog routes somewhere else

I have already tried searching and implementing advice found on this site:

  • Checked and re-entered DNS records
  • Removed and re-applied SSL cert
  • Added 303 rule to DNS
  • Added 303 rule to IIS (Windows 2012/IIS 7)
  • Added 303 rule to site itself
  • Checked nothing is in the HOSTS file

None of this has any effect. www.pawchester.dog takes me to an empty Umbraco site (maybe Umbraco cloud?). Could some one give me a clue where I should be looking please?

Thank you.

It appears you’ve got everything set up for the domain name correctly in DNS however based on this information.

Sounds like the web hosting that you’ve got it’s not configured to respond correctly to request to www.pawchester.dog I would consult with your host or web server manual. As something has indeed gone wrong normally most web hosts are configured to respond to both.

However you may need to set up the WebServer to respond to request via www.

Thank you for replying, Kyle.

The Web Server and IIS are under my own control - set up on a private Azure VM.

They host my other sites as well, all of which are working properly. If you are referring to the bindings in IIS then these have be removed and re-added to ensure I am covering both http and https for both pawchester.dog and www.pawchester.dog. I have also cleared the HOSTS file.

This is why I am stuck! Have you (or anyone) got ideas? I am happy to pay someone for support on this one as it has cost me a full day of investigation so far…

I can paste up any settings pages anyone wants to see…

Thx

Hi @jonathonberg

It’s not your hosting side of things, I can confirm that by just sending the requests directly to your server bypassing Cloudflare. When sending requests for www.pawchester.dog to your server it responds with the 200 OK and the same page contents as non-www.

I do however notice that your screenshot shows a wildcard (*) A record proxied as well as www CNAME however your origin server is not configured to accept *.pawchester.dog

The issue seems to be something on your Cloudflare end as only when sending requests via Cloudflare can I reproduce your issue.

Can you confirm if your using an Cloudflare Enterprise account? And send screenshots of your “Page Rules” & “Transform Rules” in Cloudflare.

User2765 - thank you for the response.

I am using the FOC account type in Cloudflare. Not because I am tight but because I get what I want (SLL origin certificate and SSL redirects) within the FOC package. I will happily upgrade the account if that will fix the issue.

Re: Transforms - I have no transforms.

Re: Rules. There is only one that I put in to try to correct the issue I am having.

Thank you.

No need to upgrade. I just wanted to double check because I saw you had a proxied wildcard record which was previously only for Enterprise plans, but seems that Cloudflare has now allowed anyone to create a proxied wildcard record on Free Plan nowadays.

Hi Jonathon,

you seem to be using Umbraco. Is that right? Have you enabled anything Cloudflare related with them? If not, have you ever enabled anything Cloudflare related with any other previous provider?

Your case appears to be the typical one, where the domain is still under the control of Cloudflare partner and that overrides not only your account settings, but also the DNS records, which is why you are getting wrong content. It simply fetches it from a different server.

You’d need to make sure you disable that integration, either with your current or your previous host, and if you can’t do that yourself, you best contact the host in question and ask them to manually delete your domain from their Cloudflare integration.

1 Like

Dear Sandro

That was it! Thank you!

I never considered the “previous history” of the domain. I initially tried to set the site up on Umbraco Cloud and they still had the www domain as “protected”. Your clue was all I needed to break through the issue that has had me stumped for days.

THANK YOU VERY MUCH!

Best regards

Jonathon.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.