Www alias DNS problems

Hi

I have a site actively going though Cloudflare. Unfortunately the www requests are not connecting. Getting 522 error which I presume means Cloudflare cant proxy to my aws instance but also sometimes get unable to connect error.

Checked DNS and i see the correct IP listed in a record section but fwd3.hosts.co.uk listed for the cname www part. Does that sound correct?

It may well be that my server (running apache) needs more work on the www alias

thanks

Did your site load fine on HTTPS before you added it to Cloudflare?

not sure - i rarely type in www so I’ve only noticed the problem. https without www - yes pretty sure was fine before cloudflare. I am using certbot and its configured correctly. I had “flexible” set in cloudflare (but since changed to full) and also have always automatic https rewrites enabled in CF. Hopefully its not conflicting somehow

thanks

Change that to Full Strict for starters.

done - thank you

If the DNS setting sound correct in CF to you guys, then I will putting this down to my apache config for www that I’ll need to check. All I have done is add www.mydomain.com as an alias but this is will probably go a little off topic

The important thing is that your site loads fine on HTTPS before you add it to Cloudflare. If that’s the case, it will also work fine on Cloudflare.

What’s the domain?

It worked fine with https - that’s not the issue. The problem is it won’t load using www as a prefix. Fine without it.

Unfortunately cant share the FQDN as its work related.

In that case this will be a configuration issue on your server side. You could use the appropriate redirect from #tutorials.

Turns out it was the cname I mentioned in my initial post. I removed that and added another A record for www version of the site with correct AWS IP and all is working as expected.

If the CNAME record pointed to the same host it isn’t a problem. If it points to another, it of course won’t work.

[quote=“user3254, post:1, topic:319616”]
Checked DNS and i see the correct IP listed in a record section but fwd3.hosts.co.uk listed for the cname www part. Does that sound correct?
[/quote/

exactly what I stated in my initial post. Anyway, all good now.

Without full information it’s a tad difficult to give advice. That’s why it’s important to always provide as many details as possible, e.g. the domain

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.