Wrong node module detection when using @noble/secp256k1

I want to use the npm package @noble/secp256k1 in a Cloudflare worker. This package works both on node and in the browser. The only difference is the source of the crypto module. I believe the browser version should work fine with a worker but I am getting this error:

✘ [ERROR] [plugin checkForNodeBuiltins] Detected a Node builtin module import while Node compatibility is disabled.
Add node_compat = true to your wrangler.toml file to enable Node compatibility.

    node_modules/@noble/secp256k1/lib/esm/index.js:2:28:
      2 │ import * as nodeCrypto from 'crypto';
        ╵                             ~~~~~~~~

I do not understand why wrangler tries to load the node version instead of the browser one.

Does the problem come from the library itself that does not detect the environment correctly?

Or is there a fix on the worker side to force to use the browser version?

Thank you.