Wrong index.php file loading for my website

Looking for some help with an issue that began today based on some updates to my site recently.

I took over management for an older site which was originally developed in WP. The public portion of the site (everything before a user logs in) was rebuilt outside of WP recently using all .html files. A few weeks ago, I rebuilt those same files using .php instead to add dynamic capabilities (I am more of a backend, php developer myself). I also updated my .htaccess file to drop the .php from files in the URL for cleanliness.

Starting this morning, the main site’s url began loading a very OLD index.php file from WP rather than the new index.php that I built a few weeks back. After talking to SiteGround support, they suggested the issue lie in the .htaccess file and redirects there. I disabled the redirects, and the site is now loading back to the index.html file in the interim.

Hoping someone could point me in the right direction of either entirely REMOVING the WP files or fixing my .htaccess redirects that are “pointing” to that old index.php?

It doesn’t sound like this involves Cloudflare at all. Cloudflare doesn’t host WP files or .htaccess.

Great! Appreciate all the “support”.

1 Like

If WP was installed using a tool like Softaculous you should be able to uninstall it using the same tool. If not, it’s a bit trickier - gotta manually delete all the WP files and directories + the DB. A good place for help on this is Fixing WordPress | WordPress.org

Re. htaccess, just delete the line doing the redirecting.

1 Like