Wrong A-Record of o1.office.mobisystems.com using Sendgrid owned IP 198.37.146.154

The problem is that the Cloudflare user mobisystems.com uses a wrong A-Record (198.37.146.154). This IP is owned by Sendgrid for sending out emails. Reverse-lookups are performed to this IP, e.g. from our domain eventyay. com when using Sendgrid.com. As Cloudflare shows the A-record for mobisystems. com Emails are rejected or are marked as Spam.

Solution: mobisystems.com needs to remove the wrong A-record.

Below I am adding the info from our Google cloud support and Sendgrid support. Please remove the A-record 198.37.146.154. It is not owned by mobisystems.com, but by Sendgrid as the below excerpts from Google cloud support and Sendgrid support confirms.

How can I reach Cloudflare, so they can work this out with the user?

LAST MESSAGE FROM SENDGRID SUPPORT

Hi There,

This is xxxx with our Tier 2 Support Team, and I’ll be helping out here. When it comes to the 198.37.146.154 IP address, while we do own this IP address, the IP address is managed by the reseller. It’s up to the reseller to remove current rDNS assignment. Unfortunately, there won’t be more we can do on our side at the moment regarding this. As the Google Support member mentioned, the DNS record is currently on CloudFlare. If anyone is able to remove that record, it would be their Team.

I hope that clears things up for you. Let me know if you have any additional questions regarding this.

Best,
xxx

MESSAGE FROM GOOGLE SUPPORT

Let’s take a look at your domain:

$ dig eventyay.com +short

172.67.209.180
104.21.45.48

Neither of those records have a reverse lookup configured:

$ dig -x 172.67.209.180 +short
$ dig -x 104.21.45.48 +short
$ dig -x 172.67.209.180 +trace
$ dig -x 104.21.45.48 +trace

If you want a reverse lookup for your domain, the owner will have to set it up in Cloudflare.

PART 2 Answer from Google

The Free Accounts pool that you are on is under a Google reseller account. The IP, 198.37.146.154, belongs to the Google cloud reseller account. So to clarify, google is in control of the IP here. We are pointing to a proxy on our side hwproxy0039p1iad2.sendgrid.net . Having said all this, this value can be changed but it would be on google’s side. I would open a support case with your reseller account and have them address the rDNS on the IP.

Whois Lookup Captcha

PART 4

The IP is owned by Sendgrid but there’s an A record for it in Cloudflare:

$ dig o1.office.mobisystems.com +trace

mobisystems. com. 172800 IN NS lisa.ns.cloudflare. com.

mobisystems. com. 172800 IN NS matt.ns.cloudflare. com.

o1.office.mobisystems. com. 300 IN A 66.226.77.22

;; Received 70 bytes from 172.64.32.131#53(lisa.ns.cloudflare. com) in 21 ms

Because this domain is not hosted in GCP Cloud DNS, we can’t make any changes. Whoever owns that domain will have to edit the A record in Cloudflare.

Please get Cloudflare involved if necessary or at least forward this information to Sendgrid. There seems to be a misunderstanding.

Sincerely,
Google Cloud Platform Support, Montreal

Cloudflare cannot alter the settings in a customer account, you’d need to reach out to the domain owner via their site to ask why they’re using the IPs.

I really don’t think that even if you got that Cloudflare customer to remove their “A” record (see next paragraph), that it would fix the problem. The problem is the Reverse DNS lookup for that IP address. And, as some of your messages say, that’s the snag. Cloudflare can do nothing about that reverse DNS lookup for an IP address that belongs to Sendgrid.

A forward DNS lookup for o1.office.mobisystems.com (the “A” record) does not return the 198 IP address, so I don’t see that you can get any resolution here.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.