Wrangler & Workers KV

Hello, I migrated to the 5$ plan but I get this for workers KV

Also, “wrangler publish” returns an error status 400,

:arrow_down: Installing wasm-pack…
:arrow_down: Installing wranglerjs…
Built successfully.
Error: ErrorMessage { msg: “:no_entry: Something went wrong! Status: 400 Bad Request, > Details {“success”:false,“errors”:[{“code”:7000,“message”:“No route for that URI”}],“messages”:,“result”:null}” }

“wrangler whoami” succeeds though

And I have a workers.dev subdomain…

Does anybody have some hint??

have you refreshed Cloudflare Dashboard?

Wrangler has an issue binding KV namespaces.

Can you show wrangler.toml omitting zone_id account_id?

yes

name = “tkakuge-serverless”
type = “webpack”
zone_id = “”
private = false
account_id = ”****"
route = “”

(thanks for your help! hope we can find my problem, i am really excited by that new technology!)

Yesterday, I report this issue. does it fit your case?

I don’t know what a zone_id is…
In the documentation here https://github.com/cloudflare/wrangler it is written “zone_id” and “route” are optional when working with a “workers.dev” subdomain. How do I tell wrangler I am working with a workers.dev subdomain? I suspect it might be the problem…
I did a little bit of googling and tried using the big sequence of numbers and letters that show up in cloudflare urls by I get the same error (code 7000 no route for that URI)…

I found the problem with the big roundabout (rust debugging and api calls…)

The “account_id” is the number in the URL, not my email address…

I still have the problem not begin able to use Workers KV but I filed a ticket for it. It seems like a real cloudflare issue, hopefully it gets solved.

Is you workers plan active now?