Wrangler login problem

When I try to login with wrangler login command, I accept the authorization in opened new page but in console it stuck and waits. I tried to login with global api key and it says :

Error: Authentication check failed. Please make sure your email and global API key pair are correct.

I tried to enter the api key via config it says:
💁 Validating credentials…
Error: Authentication check failed. Please make sure your API token is correct.
:warning: Code 6003: Invalid request headers

I can not login my account via wrangler cli

I have already logged in with different account, I want to change current account.

I expirience the same issue. Any news on this?

Hello! Logging into your intended Cloudflare account in the browser, then running Wrangler Login should authenticate you to the right account.

Could you try this process again and see if you get that error?

If that doesn’t work, shoot me an email at [email protected]

Hi Azhao,

I’m getting the cors error on the permission page, so when i click allow nothing happens.


i think this is an error on cloudflares part.

Have you contacted Cloudflare support? You can share the ticket number here later on.

cc @Walshy in case he has some insights about this issue.

1 Like

Hey, I can reproduce the cors error, however, I was still able to login. It just took a while (7.9s for me). Try clicking allow again and just waiting a few seconds.

I will send this up to the team and let them know

1 Like

yep after a couple of timeouts, finally worked. just a one off bug i guess.

The CORS error is a red herring, it doesn’t affect functionality. We did discover an issue for non-US logins tho, that was contributing to it taking 6-10 seconds to complete login after clicking “Allow”. This has now been resolved; it’s much faster, and the UX is slightly better too, with a spinner being triggered on clicking the button.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.