WpAllImport Work not working under Cloudflare

I’ve got a WordPress site under Cloudflare.

The site is working fine except I have to enable massive import using WPAllImport plugin.
It actually fails every time I try to launch the import work after 100secs

I’ve checked the docs and the internet and it looks like it’s a problem due to Cloudflare blocking long lasting processes.

I’ve tried to add an exception rule but I’m not sure if it’s working.
Well, I’m sure it’s not working since the import is still failing but I don’t know how to check if the rule is correctly triggered.

The page that holds the import process is inside the wp-admin area and it has a query string attached reporting wp-admin/admin.php?page=pmxi-admin-manage

Is there a way I can bypass the action of cloudflare when I run this action?


This is not something Cloudflare WAF or any other security feature would do. For that reason, an exception rule would have no effect. This is probably a 522 error, which happens when the server stops responding for a while. In cases like this, you may wanna try WP CLI if your hosting provider offers this tool.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.