WP Plugin Setting Screen Blank

Hi all, has anyone encountered this issue before – upon installing the Cloudflare WP plugin, the admin screen is completely blank. Console message loading errors say:

Failed to load, plugins/cloudflare/en.js (406 error)
Couldn’t load content for stylesheets/components.css.map

That .map file mentioned doesn’t even appear to be in the installation?! Any ideas how to resolve this?

We’ve already tried the following:

  • Clearing browser cache and going to Dev Tools, set Disable Cache in Dev Tools and then refresh the page. (as per Cloudflare Settings page is showing blank in wordpress admin after installing and activating cloudflare plugin in wordpress)
  • Disabling various plugins like WP Rocket and retrying (a few posts online said to disable the WP All In One Security plugin, but we don’t use this or any other security plugin for that matter)
  • temporarily pausing Cloudflare
  • rolling the plugin back to a previous version (4.5 and 4.2)
  • using other browsers
  • contacting support (it’s been 10 days already and they haven’t really given any useful advice), we just got a generic response “A 4xx Client Error is a client-side error indicating problems with your hosting provider or the client request.”

The site is hosted on Azure. Any advice would be much appreciated.

was just dealing with the same issue myself for hours.

this is what worked for me just now:
the console was indicating one resource (www.example.com/wp-content/plugins/cloudflare/lang/en.js?ver=4.7.0) was failing with code 406.

i opened up a new tab and pasted that url in there. the url pulled up fine, a bunch of js code. then i went back and refreshed the cf plugin settings page and the page filled in.

hth

Thanks retroman, that did in fact fix the issue.

So wierd.

Hopefully Cloudflare will fix their plugin

I spoke too soon. Whilst it did display the settings page, it appears the plugin isn’t being recognised by Cloudflare because a) despite toggling the auto platform optimization on in the WP Plugin it isnt working, b) when I purge everything no green bar appears c) in Cloudflare itself in Speed > Optimization the equivalent auto platform optimization toggle isn’t on and there is a message: “Note: The WordPress plugin was not detected on rainforestcruises.com. Check again.”

@retroman did you experience the same?

worked for me. of course had to plug in my email and token first and submit.

it does stop loading and i get the blank page after a while again so i have to go to another tab and load the js url again and then refresh the plugin settings page to see the content.

as i noticed, technically you don’t even need to see the settings page for apo to work. check to see if apo is even working at all for your site. https://developers.cloudflare.com/automatic-platform-optimization/get-started/verify-apo-works

it doesn’t appear it’s working for your site. maybe try toggling apo. also deactivate security/caching plugins if any and see how that goes.