WP Engine + Cloudflare CNAME Problem


#1

Hi there,

I’m pretty new to all this - so forgive me if I’m missing something obvious.

I have recently migrated over to WP Engine from Closte.com hosting. I’ve also just started using Cloudflare.

As per the WPEngine instructions I have set up;

  1. The correct nameservers on my registrar
  2. The CNAME in Cloudflare to point to my WP Engine address (paulwood.photogprahy -> paulwoodphoto.wpengine.com)
  3. The default domain in WPEngine to paulwood.photography

However, now whenever I type in https://paulwood.photography into my web browser I am redirected to paulwoodphoto.wpengine.com

Is anyone able to hep advise what I may be doing incorrectly - and even if I should be looking on the WPEngine side of things or the Cloudflare side of things?


#2

On the crypto tab check to make sure you’re not using flexible SSL (set ti to full).


#3

Thanks,

The crypto tab is set to full (strict)


#4

It appears to be an issue on the WPE side of the config. Send them the following and it should hel them confirm:

curl -Ik --resolve paulwood.photography:443:you.ip.address.at.wpe https://paulwood.photography
HTTP/2 301
server: nginx
date: Sun, 25 Feb 2018 20:17:02 GMT
content-type: text/html; charset=UTF-8
content-length: 0
location: https://paulwoodphoto.wpengine.com/
wpe-backend: apache
x-cacheable: non200
cache-control: max-age=600, must-revalidate
x-cache: HIT: 4
x-pass-why:
x-cache-group: normal
x-type: default


#5

Thank you,

Apparently there was some hard coded redirects in my config file that may have been from the migration process.

WP Engine staff were able to fix it up in a couple of minutes.

Paul


#6

This topic was automatically closed after 14 days. New replies are no longer allowed.