WP Cloudflare Plugin PHP 7.2 issue


#1

Hello guys, I decided to migrate to PHP 7.2 or 7.3 on my server for Wordpress.

But I found the following issue with the CloudFlare plugin:

> FILE: /home/...../public_html/..../wp-content/plugins/cloudflare/vendor/cloudflare/cloudflare-plugin-backend/src/SecurityUtil.php
> ------------------------------------------------------------------------------------------------------------------------------------------------------
> FOUND 2 ERRORS AFFECTING 1 LINE
> ------------------------------------------------------------------------------------------------------------------------------------------------------
>  16 | ERROR | Function mcrypt_create_iv() is deprecated since PHP 7.1 and removed since PHP 7.2; Use random_bytes() or OpenSSL instead
>  16 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
> ------------------------------------------------------------------------------------------------------------------------------------------------------
> 
> FILE: /home/...../public_html/....../wp-content/plugins/cloudflare/vendor/symfony/yaml/Parser.php
> --------------------------------------------------------------------------------------------------------
> FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
> --------------------------------------------------------------------------------------------------------
>  76 | WARNING | INI directive 'mbstring.func_overload' is deprecated since PHP 7.2
> --------------------------------------------------------------------------------------------------------
> 
> 
> FILE: /home/...../public_html/...../wp-content/plugins/cloudflare/vendor/symfony/yaml/Inline.php
> --------------------------------------------------------------------------------------------------------
> FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
> --------------------------------------------------------------------------------------------------------
>  55 | WARNING | INI directive 'mbstring.func_overload' is deprecated since PHP 7.2
> --------------------------------------------------------------------------------------------------------

What should I do?

Kind regards, Paul.


Cloudflare plugin 3.3.2 is not compatible with PHP7.2
#2

Who issues these warnings? As far as I can tell from https://github.com/cloudflare/cloudflare-plugin-backend/blob/6fba096b2fac8fda92b4e27a047c083559a9a633/src/SecurityUtil.php#L14 mcrypt_create_iv should only be called if it actually exists, by default it already uses random_bytes.

:+1: for the migration to 7.2, though.


#3

Hi Sandro, thank you for your answer.

I used " PHP Compatibility Checker" plugin.

Also SG Optimizer from SiteGround also didn’t recommend me to update to 7.2 due to the plugins errors.


#4

So, its not an error during runtime?

Regarding the recommendation not to upgrade, I cant comment on other errors, but these two should not be a problem I’d assume. That compatibility plugin does not seem to go too much into detail.


#5

This topic was automatically closed after 14 days. New replies are no longer allowed.


#6

Cloudflare WP plugin is not compatible with PHP 7.2 or above, we do not have any ETA when a new version will be made available to support PHP 7.2 but will post back when we do.