WP Cloudflare installed and new posts don't show in my homepage

Hi everyone, I need some help - I’ve installed and configured (with the wizard guide) within Wordpress Cloudflare but since then every post I publish don’t show up in the homepage of my site under “Recent Posts” - but only when I reload the page…

Can you guys/girls help me out with this issue? are there some parameters I should enable/disable on cloudflare or in the wp plugin itself to let the blog run smoothly?

Thank you!

May I ask do you also have some caching setup configured either at WordPress (using some Cache plugin) or Cloudflare end (using Page Rules or Cache Everything option)?

1 Like

Hi! I’m using only WP Cloudflare (the plugin) and through that I registered on cloudflare.com here as page rule I have Cache Everything

I believe this is the reason why you do not see new / recent posts (why do not they appear) on the homepage either you created/posted new one.

Try switching to “Standard” and see if anything different.
Also, try to Purge the Cache at Cloudflare.

Because having “Cache Everything”, could mean even to cache your homepage (HTML webpage) for selected/defined time at Cloudflare dashboard, meaning it will keep a cached version of your homepage for minutes, hours, or even days or longer.

Cloudflare does not cache HTML by default.

More about it can be read here:

1 Like

still very perplexed, I now have it Cache Standard but the problem persists

As @fritexvz mentioned, it’s due to your Cache Everything rule.

The Cloudflare plugin tries to purge only affected resources, but it probably misses a few, possibly including your Front Page.

Without seeing your site for ourselves, that’s about as much advice as we can offer.

2 Likes

Thanks to both of you! I see, but the caching rule I have is Standard not Everything - sorry forgot to share the site selkietraveller.com

When landing there you’ll see a post about burning wicks but if you reload it 2 more posts will appear. I have W3 Total Cache as plugging other than Cloudflare.

Are you sure?

Something is caching your home page, as evidenced by the x-cache header. That is coming from your server. Cloudflare cache status says DYNAMIC (not cached), so I guess you were right the second time regarding Cache Everything.

2 Likes

image

So it might be something else…hmm

I removed the W3 Total Cache and Purge Everything from Cloudflare - let’s see - I don’t have anything else caching on Wordpress now

nothing seems to change - still have the same issue, any idea? Page rule is Cache Level: Standard

those are the plugins I have on the website, I even removed W3 Total Cache.

Hm, that’s kinda weird.

Going back to this now, which I may have overlooked the first time around.

Are you saying that if you Force Reload the home page, the new posts show up? That would imply it’s a Browser Cache setting.

yeah but I did clear it up in my browser and nothing really change, also tried in different browsers after cleaning the cache, you can try it yourself…don’t know what to do really…hmm

@fritexvz @sdayman I may have solved the issue, I guess it was server-side caching (?!) basically, I logged onto gandi and purged the cache from there and it should be fine now…really thank you for helping me out!

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.