Wp-admin page is not working after enabling Cloudflare SSL

Hi,

wp-admin page is not allowing me to login, it is not showing me the login prompt, It is just showing coming soon page. It happened after enabling Cloudflare free SSL.

Here is what I have done:
1)Created Cloudflare account and added site.
2) Selected free SSL of type flexible
3)Added page rule to always use https
4)Installed Cloudflare and Cloudflare flexible SSL plugins on Wordpress
5)Connected to cloudlfare account using Global Key in Wordpress Plugin
6)Not Changed Wordpress Address (URL) to https, but changed Site Address (URL) to https under Settings -> General in wordpress.
7)Changed DNS names in cpanel to the DNS names given by Cloudflare

Now, I end up with this situation. Can one one help me what to do now and how to fix this?

I believe that Step 6 is the problem. Flexible SSL connects to your server with HTTP, but Wordpress is telling it to come back on HTTPS. Try changing that Site Address back to HTTP.

This topic was automatically closed after 30 days. New replies are no longer allowed.