WP-Admin access

Sorry if this was answered somewhere else. After setting up the name servers to point to Cloudflare I can’t access the web-admin page to login. I have an .htaccess file that only allows certain IP’s to connect to the admin page.

Because everyone (including me) is flowing through the proxy, is it possible to allow my IP address to bypass the proxy on the “FREE Tier” of cloudflare. I’ve followed a recent document to allow an IP it bypass, but it still doesn’t seem to work for me. Any ideas? Thanks in advance!

  1. It sounds like your server isn’t configured to restore the IP address of your visitor based on some headers that Cloudflare sends:

  2. An easier/better solution is to use a Firewall Rule:

  3. The slickest solution is to use Access. It’s free for less than 50 users. I have mine set up to bypass the block if it’s my home IP address, and if I’m not at home, it will email me an access code to a specific email address.


I changed the Firewall rule to match the structure you suggested but I still get the servers response.

I need the server to see my IP address. The access is controlled at the server not at CloudFlares level.

If you still want to use .htaccess to block, then you’ll have to go with my Option #1.

1 Like

I put that in place and it still didn’t work for me. I followed along just as it said. Is there something else I can try?

Yes, get rid of that .htaccess rule that blocks by IP address and use either Option 2 or 3 from my original response.

This topic was automatically closed after 31 days. New replies are no longer allowed.