Wp-Admin 404

Hello, I would appreciate any help on how to access my wp-admin page.

I switched on Development Mode yesterday morning and added these two page rules, and could access the login page. However I got a 404 error page when I next checked in the evening, and I can’t access the page today either.

My page rules are set up as:

1
mysite.net/wp-admin*
Security Level: High, Cache Level: Bypass, Disable Apps, Disable Performance

2
mysite.net/*
Cache Level: Cache Everything

Other details: SSL/TLS encryption mode is Full (CF cert added to host), Always Use HTTPS Redirect enabled, Automatic HTTPS Rewrites enabled.

Under the CF Health Check, I have errors on DNSSEC configuration and DS record configuration.

Thank you!

I advise against adding a Cache Everything rule to WordPress, as it usually doesn’t go well unless you’re on a Business or Enterprise plan that lets your bypass cache on cookies. Dev Mode bypasses the cache until dev mode auto-disables a few hours later.

For WordPress, I suggest using APO with the Cloudflare plugin ($5/month on free plans).

1 Like

404 should indicate the host error. Do you block something or have re-writes for login or have had a “typo error” so you got the 404 not found?

May I suggest to go vice versa and setup the Page Rules as follows:

The Page Rules from the above screenshot should work if you have some caching plugin installed at your origin/host like W3 Total Cache - but that is an advanced way, and you need to understand other things.

It’s better to have Cloudflare APO for WordPress as @sdayman suggested, and you just have to “click” and have it all (or mostly all) done with that, nothing else as usually :slight_smile:

Just to note here, you can use Firewall rules to protect your WP-login page - that’s why here we have “Low” for Security Level, while the general Security Level is setup as “Medium” at Cloudflare.

Due to Cache Everything, be sure to setup your cache HTTP headers at your origin and having “Respect existing headers”:

That is the way. Great!

Regarding the DNSSEC, the DS record which you get by clicking the button “Enable DNSSEC” at Cloudflare dashboard, you need to give it (or add it yourself) at your domain registar.

  • maybe they do not support DNSSEC, or not that algorithm “13”, if that is the case, then you cannot use DNSSEC for your domain (there are topic regarding it either people wanted to put their own DS record to Cloudflare with an older and unsupported algorithm and the “ZSK”)

Hello @sdayman and @fritexvz – thanks for your help and tips. I will keep the plugin in mind!

I managed to access the login through pausing Cloudflare and having a look at plugin settings. I had forgotten about a setting on my security plugin that was blocking the login. The pause feature was very helpful.

2 Likes

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.