Workers Sites with a custom domain in Cloudflare Registrar

Hi there,

just started using Worker Sites! Really excited to see this feature. The good news, I can work through the quick start tutorial an dmake everything work on That all works like a charm. :+1:

Next I tried to make it work on a domain I transferred to Cloudflare Registrar. Unfortunately I can’t make it work on my custom domain (

$ cat wrangler.toml
account_id = "hidden"
name = "www"
type = "webpack"
workers_dev = false

bucket = "./public"
entry-point = "workers-site"

zone_id = "hidden"
route = "*"

I can publish, but the site does not get resolved. Which isn’t surprising because I don’t have any DNS records set for the domain. I only parked it at Cloudflare.

$ dig

; <<>> DiG 9.10.6 <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 7638
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 1452
; IN A

;; AUTHORITY SECTION: 2724 IN SOA 2032117724 10000 2400 604800 3600

;; Query time: 27 msec
;; WHEN: Fri Sep 27 18:53:44 CEST 2019
;; MSG SIZE rcvd: 102

Question is: how to make it work? Do I need to setup a CNAME record pointing to

with kind regards

1 Like

Solved it. All it takes is adding an A record pointing to

All credits go to this post:

I think you meant which is an unused IP. The address is publicly routed.