Workers not working in route when published

The code is working on the sandbox, but as soon as published, does not work on the live site.
I have checked the existing discussions around the same and would like to point out that the DNS is active. Have tried the dashboard as well as wrangler, but no luck.

Any Firewall Events showing as “blocked” or “challenged” maybe, or some errors appear in the Console? :thinking:

No blocked or challenged events.

In the console an error is thrown:
Uncaught (in promise) TypeError: Cannot convert undefined or null to object
at Function.keys ()
at companion-bubble.js:1465:19716
at ()
at Ln (companion-bubble.js:1465:19134)

But after reading some article, I opened the same URL incognito, the above disappeared, but worker still did not work.

Another piece to add here, the logs are empty when the URL is hit on the route, whereas it works on the sandbox.

Have you checked in the workers discord?

Meet The Workers Team Over Discord (

Hello, I suggest you disable or remove your chrome or firefox extension and retest. This worked for me.