Workers Internal Error on multiple sites since 18:45 UTC

Not sure what happened, but my sites running on Workers started to fire Error 1101 Worker threw exception for ~50% of requests a couple of hours ago, and the errors in dashboard aren’t helpful at all:

"outcome": "exception",
  "scriptName": null,
  "exceptions": [
    {
      "name": "Error",
      "message": "internal error",
      "timestamp": 1632339943164
    }
  ],
  "logs": [],

if I press Quick Edit, the worker works fine in that test environment.

Where do I start? The workers were working fine for a couple of days previously.

The account is in Durable Objects beta, if that changes something, but the workers in question are “regular” ones (not modules, not using anything apart from KV and fetch API)

Umm. How do I edit the post title? Can’t find the button :confused:

Worker errors began since about 18:45 UTC.

UPD: got the ‘basic’ level and edited ))

We have same problem!

Oh. Interesting! Good to know. Just filed a support request 2263321 and mentioned you

Let me pass this on to the team, not seeing an issue my end though

1 Like

@Walshy Just noticed the “priority” field on the ticket changed to Urgent. Curious :slight_smile:
The CC field says “Timothy joseph Cloonan”, if that helps

1 Like

We detect some problem with access to KV

It works again!

@5uu5 cool! i’m not that lucky, my monitoring still shows websites are down. Can you check https://tvori.info/ ? (it should show a very very simple page saying “you are probably looking for my blog”)

sorry. we just disabled KV

@Walshy @5uu5 Isolated an issue.

Repro TLDR: JSON.stringify(event) where event is FetchEvent. Worked fine previously (used it for debugging), crashes the worker (try/catch doesn’t help) now.

That’s @cloonan, the community manager here. I guess he bumped it up in priority :slight_smile:

1 Like

I did not but I will find the ticket to take a look

Oh, you were CC’d in automatically by the mention here :slight_smile: Gotcha!

1 Like

I’m not able to repro that, here is my attempt at a PoC:

addEventListener("fetch", (event) => {
  let res;
  try {
    res = new Response(JSON.stringify(event));
  } catch(e) {
    res = new Response(e.stack, { status: 500 })
  }

  event.respondWith(res);
});

(Available here: https://worker-error.walshydev.workers.dev/)

Could you share some code where you can reproduce this?1

  1. it should work without errors on workers.dev (worked yesterday at least) and wrangler dev
  2. sure, i’ll make a standalone repro later

Yeah even on a normal domain it works for me but I will forward what you mentioned to the team either way
https://worker-error.walshy.dev/