Workers don't work on cellular data

My workers are not accessible/usable from my cellphone data (Vodacom) but works fine on Wifi. When I change my DNS server to 1.1.1.1 everything works/

Greetings,

Thank you for asking.

May I ask you to post and share your domain name in bracketed dot [.] notation here with us so we could double-check, troubleshoot and provide some feedback information? :thinking:

What error do you get? Can you share a screenshot if it, if so?

Before moving to Cloudflare, was your Website working over HTTPS connection?

May I ask if you’re testing over the Workers sub-domain or your own domain? :thinking:

Maybe it is due to the fact that DNS didn’t propagate so fast if you’ve changed something at the DNS tab of Cloudflare dashboard for your domain name and that there is something “stuck in the air” at DNS cache of your local ISP of your mobile phone (4G LTE, mobile data, cellular) :thinking:

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.