Workers Cron Triggers triggering wrong days


using the new workers cron triggers, but there seem to be some issues with the cron schedules.

I have it set to trigger every weekday, the actual help message also says mon-fri.
However, it doesn’t trigger on fridays, but on sundays.
after the friday trigger should have triggered it says “next scheduled: Monday” as it should.
I can confirm that it actually is triggering on sundays instead of fridays.

Anyone else seeing this?

I haven’t seen this error.

Can you try this?
30 06 * * 1-5

PS: I reported it to PM.

This is Interessting.
Has to do with the system locale they are using in this Case en_US.UTF-8 aka United States, English
Becouse of this the first Day in the Week on the System is not Monday but Sunday.
As per your Settings Cron does everything right as it execute the Worker on the first Day of the Week aka Sunday followed by Mon, Tue, Wed and Thu.
That the Webpage says it will execute the Worker on monday has to be the result of a missmatch in locales between the system locale and visitor webpage language locale setting in this case de_DE ISO-8859-1 where Monday is the first Day of the Week !
If you want your Worker to execute on Firday and not on Sunday you will need have the following Cron

30 06 * * 2,3,4,5,6

For more Info about Sunday first Day in Week see here:

While, for example, the United States, Canada, Brazil, Japan and other countries consider Sunday as the first day of the week, and while the week begins with Saturday in much of the Middle East, the international ISO 8601 standard[a] has Monday as the first day of the week.

1 Like

30 06 * * mon-fri sorts the issue
Though it looks there is a bug there, two different locales, system and user.


Looking at normal man pages for crontab 0 = Sunday, so 1,2,3,4,5 should be correct.

mon-fri works for me tho!

Thanks both!

Woops. Looks like we forgot to tell the UI to start days of the week at 1. In the service that executes these we wrote the parser to match the behavior of Quartz schedulers which start days of the week at 1. The parser we use on the dash to provide descriptions wasn’t told this and assumed it starts at 0. So once it gets to the backend it thinks you specified Sunday, when the UI told you Monday.

For now, MON-FRI will work. The UI will be fixed soon.