Workers Cron does not run

The Cron trigger deployed today will not run.
I tried deploying such a simple code, but it didn’t work either.
Press the “Trigger scheduled event” button on the quick edit screen of the Web UI, and it is executed normally.

index.mjs

export default {
  async scheduled({ scheduledTime }) {
    console.log(scheduledTime);
  },
};

wrangler.toml

name = "index"
main = "index.mjs"
compatibility_date = "2022-06-19"

[triggers]
crons = ["* * * * *"]

It is not uncommon for cron triggers to take up to ~30 minutes to deploy. Are they still not running?

Yes. Not running.
The cron worker listed above was deployed 5 hours ago.
In addition to that, we deployed a cron worker that runs every hour (“0 * * * *”) 3 hours ago, but both are not running.

Cron also doesn’t work for me. (The event listener ‘scheduled’ is called when I manually press the “Trigger scheduled event” in the editor.)

My cron job set to 0 0 * * * also didn’t work (I deployed it yesterday and it didn’t trigger today at 1am UTC when it should have), even though it does when I manually trigger it in the dashboard.

@mo36924 @patrik.martinko @danielnhoward93
This should now be working again. Please let me know if you are still experiencing issues.

2 Likes