Workers.api.error.script_not_found error in Wrangler publish

I have a existing Gatsby-js site. wanted to move it to CF. so I followed this guide https://developers.cloudflare.com/workers/platform/sites/start-from-existing everything works great until the step 6.

I am getting following error in steps 6

 Built successfully, built project size is 13 KiB.
 Using namespace for Workers Site "__static-site-workers_sites_assets"
 Success
 Uploading site files
Error:  There was an error fetching your subdomain.
 Status Code: 404 Not Found
 Msg: {
  "result": null,
  "success": false,
  "errors": [
    {
      "code": 10007,
      "message": "workers.api.error.script_not_found"
    }
  ],
  "messages": []
}

Is there a setting I need to do on CouldFlare dashboard? AFAIK wrangler should create necessary workers in order to publish this site isn’t it?

Do I need to point domain to somewhere from DNS feature?

I was eager to see this all (wrangler, CF workers and KV storage) work in action but this was a big let down. So currently the site is hosted on Github Pages.

1 Like

I run into a similar problem when using wrangler tail (wrangler 1.19.3):

wrangler tail
Error: Failed to create tail: :warning: Code 10007: workers.api.error.script_not_found

No idea how to fix this… Any tips welcome

hmmm, got confused by the documentation. You do not need to supply the name of the worker. Just use plain “wrangler tail”

(and of course the error feedback could have been a bit better :slight_smile: )

I gave up on this idea. I think this feature is not mature yet (at least for me to use🤷). I double checked the steps with documents before posting this question here. After getting no response from anyone from CF, I suggest not to waste time on this.