Workers always fails with auth error 10000

Hi, I have managed to get some Pages working, but when I try to create any Worker - be it template or manually created from the tutorial, I always get an error when running wrangler dev

Error while creating remote dev session: ParseError: A request to the Cloudflare API (/accounts/xxx/workers/subdomain/edge-preview) failed

...

    notes: [ { text: 'Authentication error [code: 10000]' } ],

I’ve never managed to get a Worker working. Any ideas?

I have managed to create a worker using the Cloudflare dashboard.

Quite confused now…

I am still not able to create a worker from my desktop - I always get a 10000 auth error.

Makes it impossible to proceed. Can anybody help?

What’s the output of wrangler whoami and what Wrangler version is this?

1 Like

Thanks for the help in Discord! I recreated my API token using the “Edit Cloudflare Workers” template as you suggested, and it is now working.

:grinning: :rocket:

1 Like

Hi! Could you explain in more detail how you solved it, please? I’ve tried generating a token there and providing it to wrangler1 with the wrangler config command but that didn’t help. On wrangler2, I keep getting this 10000 error every time I run wrangler dev

Nevermind, it turned out that I was lacking Cloudflare Workers Admin permission