Worker with email catch-all not working

Trying to use a worker to handle “catch-all” emails.

If I set the worker as a destination for a specific email e.g. [email protected] then the worker is triggered.

If i set the worker as a destination for the catch-all, then the worker is not triggered at all.

What am I missing?

Same issue here, did you ever figure it out? Seems like it’s a documented feature that just hasn’t been working, some people say wipe dns and retry, some say they just waited and it worked, I have yet to get it to work at all.

TLDR: Change it to send to email > change it back to send to worker > set the status to enabled. Fixed!

I had the same issue. When I first setup the catch all to send to a worker. It didn’t show a “status” on the main Routing Rules tab.

I changed the catch all to send to an email, then on the rules tab the status shows as disabled. Changed it back to send to a worker, the status now shows as disabled. Setting it as enabled fixed the issue. My worker now receives all emails.