Worker publish fails with authentication errors but

Hi,

I have created a new worker like so many times before, and it fails with an authentication error after an output stating that it is going to upload site files.
Interest info, the worker was not active and the worker rule was not there. I manually did both changes and everything started working just fine. So the files are actually being uploaded.
However, if I run the deploy process again it keeps failing even if everything works just fine.

Any idea why?


API TOKEN configuration:
Workers KV Storage:Edit, Workers Scripts:Edit
Workers Routes:Edit

OUTPUT

cd deploy && wrangler publish

added 4 packages from 5 contributors and audited 4 packages in 0.274s

found 0 vulnerabilities

Installing wranglerjs v1.10.3...

npm WARN deprecated [email protected]: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.

npm WARN deprecated [email protected]: https://github.com/lydell/resolve-url#deprecated

npm WARN deprecated [email protected]: Please see https://github.com/lydell/urix#deprecated

npm WARN deprecated [email protected]: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.

npm notice created a lockfile as package-lock.json. You should commit this file.

npm WARN notsup Unsupported engine for [email protected]: wanted: {"node":"<8.10.0"} (current: {"node":"12.18.2","npm":"6.14.5"})

npm WARN notsup Not compatible with your version of node/npm: [email protected]

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected]~2.1.2 (node_modules/chokidar/node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected]^1.2.7 (node_modules/watchpack-chokidar2/node_modules/chokidar/node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

npm WARN [email protected] No description

npm WARN [email protected] No repository field.

``

added 345 packages from 201 contributors and audited 347 packages in 6.479s

``

5 packages are looking for funding

runnpm fund for details

found 0 vulnerabilities

Built successfully, built project size is 13 KiB.

Using namespace for Workers Site "__bl-static-web-prd-workers_sites_assets"

Success
Uploading site files
Error: Code 10000: Authentication error

Are you sure your authentication code is correct? How many workers do you have in total?

Hi Soldier,

I am sure because everything got configured, but the 2 things mentioned above (flag activating the worker & and the worker route). KV was loaded with all the assets as expected.
Also, everything is working just fine. I can render the website and all assets are loaded by the browser.
My best bet is that in order to configure a route, one would need more than just “Workers Routes:Edit”.

There is a debug feature and the issue was according to my own suspicion a Zone ID mistake.

2020-07-28T14:15:58Z DEBUG reqwest::async_impl::client] response ‘403 Forbidden’ for https://api.cloudflare.com/client/v4/zones/f6271ec37ceeecce1022266bdde5dd2b/workers/routes

Sorry for bothering you all with such an insignificant error
Cheers