Worker not working when enabled for a specific route

Hi there!

I contacted Cloudflare support but they told me they cannot help me with this and asked me to post the question to the community.
The thing is that I created a worker that works fine when I test it in sandbox mode but then it doesn’t work when I enable some routes to test it in my real site.
My worker should retrieve content from a different page and it’s not doing it. It means the routes I set are not working.
Screenshot 1 is how my worker is configured.


Screenshot 2 is how the page looks when testing it in the sandbox mode (and what actually is the desired behavior)

Screenshot 3 is how it looks when I visit the page from the browser (it’s not fetching the one from the other server, as you can see, the background is different, among other differences)

Have anyone faced something similar and may know what’s going on?

I would really appreciate any help on this.

Thanks!

On the route add:
https://

*honestpaws.com/blogs/pet-care/homeopathic-treatments-for-dogs

@adaptive @Xaq thanks for replying.

I already tried both alternatives but it didn’t work either

honestpaws.com doesn’t have :orange: Cloudflare active.
Although using Cloudflare dns the :orange: but needs to be active on the DNS tab at the dashboard.

3 Likes

Thank you @adaptive. That made the trick.

Hi, I have the same issue, I tried with and without https://, www, etc… My Cloudflare proxy is activated I can see the request working correctly on the worker URL or in the preview mode, but is not working when I try to load the content on the browser, any advice ?

Thanks!

Did you get this figured out? Facing the identical issue.

Hi David101,

Yes, the issue was that the site was paused on Cloudflare, we don’t know who change this, but after unpause, all the services get back to work.

If your site is paused you will see a message on the overview page, and at the bottom right you have the following.

image

Hope it works for you.

Thanks!