Worker cannot fetch the full document

Hello to everyone,

Since yesterday we are facing an issue where all of our workers cannot handle responses larger than 800-900KB, especially (if not only) when the client has an ipv6

We are on a paid plan and this shouldn’t be happening.

Anyone else experiencing a similar issue?

Here are 2 routes of the same worker (staging site):

  • (working)
  • (halts at around 1mb)

Thank you

I get some 404s there, but nothing else.

You’d please have to be more specific.
Have you tried going to the CF dashboard and live logging the workers in question?

But if I’d have to take an educated guess, random connection cancellations smell like running out of memory while your worker is under load from multiple parallel connections.

Yes I live logged the workers, they do get a 200 response from the server which is logged as such at all cases.

The one loads correctly though, while the other leads to a semi-blank page

I cannot reproduce the error, and I don’t even get any 1 MB docs.

The point of logging would be that you can actually open the corresponding log entries, possibly while looking what happens inside your worker by adding more logging yourself.
On the forum we cannot solve the problem for you, we can only give you directions.

I am pretty sure you cannot solve the problem here, that’s why I asked if someone has had a similar issue and thank you for your time. Really appreciated

I will try with the suggestion of logging myself and if I find anything worth of mentioning I’ll post it here.

Thanks again

It seems that it was actually a CF’s problem with workers. The problem was solved 2 days after it started with me no taking any extra measures.