Work with WP Fastest cache or any other performance plugin reduces the speed

Hi, when I turn WP Fastest cache, Autooptimize or any other caching the speed decreases to literally 0. I can run WP Fastest cache with a verry good result, but I have chosen Page Rule - Disable Apps and Disable Performance and in cache plugin option Don’t show cached version for mobile devices.
Can you tell where the problem can be and how to fix it? Thanks!

Hi @gentlemans418,

I’m a bit confused by your statements. Does WP Fastest Cache provide very good result or decrease the speed to literally 0???

The Disable Apps and Disable Performance settings on a page rule are normally used for the back end (/wp-admin/ area).

The “Don’t show cached version for mobile devices” option will work only if you do not use a page rule with the “Cache Level: Cache Everything” setting.

Can you provide a screenshot of your Page Rules so that we could have a look and try to help you further?

Sorry, I didn’t mention that page rules are for my AMP.

Thanks for sharing the PRs.

You don’t need http:// before the domain on the first page rule. This will make the redirect only work if the request is for http://, but not if it is for https://.

You don’t need the * before www in the second PR. Also, I’m not sure you should use Disable Performance on that rule. You could just disable Rocket Loader and Auto Minify if that interferes with AMP, but leave the other two (Polish and Mirage) on (assuming you are, or intend to be, on a Pro Plan or higher).

So is your issue with caching plugins and Cloudflare related to the main site or the AMP pages?

Thanks for the advice. The issues are with the desktop version. The AMP works with Cache and Cloudflare very fast (over 76), but I think because the option ‘Don’t show cached desktop version for mobile devices’ is enabled. Without the plugin is about 63. The desktop is also 63 only with Cloudflare, and 0 when I activate the plugin.

I had issues using WP Fastest Cache since for some reason it was sending no-cache directives telling everything (browsers & Cloudflare) not to cache anything. I didn’t investigate if it could be fixed after that & just switched to another page & browser caching plugin (W3TC). Check the headers with your browsers developer tools to see if that’s happening for you too.

Also, Autoptimize doesn’t control your page or browser cache it just has its own cache for your content that it has modified.

Now if its actually going down to 0 then there’s something majorly wrong with your WordPress and/or server config so make sure you don’t have multiple plugins actively doing the same thing at the same time to start with.

1 Like

You were right, a problem with one plugin. PWA additional to AMP. Thank you for your help!