Wordpress with manual Let's Encrypt SSL gives ERR_TOO_MANY_REDIRECTS

cdn
bug
nameserver

#1

Hi,
I have my Wordpress website with WooCommerce. I faced many slowdowns lately, so I decided to use Cloudflare CDN to boost the speed and to enhance the performance.
My website already has an SSL certificate from Let’s Encrypt and for that, I " Turned OFF" Cloudflare SSL.
after 15 min. of Cloudflare activation the speed increased a little bit then the whole website stopped working because of this error " ERR_TOO_MANY_REDIRECTS" !!! after 5 min. it’s working again then the same problem showed up after 15 min. it’s like a loop …

how can I fix this??


#2

You need to turn on Cloudflare SSL to use HTTPS for your site.


#3

Thank you,

I created a page rule to force users to use HTTPS & switched on SSL to flexible, but the problem still showing up and the Chrome browser suggests to clean the cookies. After cleaning the cookies the website starts working again for approximately 10 min then the same error showed up again " ERR_TOO_MANY_REDIRECTS".

Now, I switched off the service from DNS page but the performance is the best !!! the pages loading speed is very good and there are no errors !!

can you explain this, please ?


#4

As you already have a valid SSL certificate, you should choose Full (strict). This should fix the redirect issue. You should also set the DNS record to :orange:.

When you switched off the :orange:, it disabled the Cloudflare features so worked as previously, just using Cloudflare DNS.


#5

yes, I have Let’s Encrypt SSL but I am not sure what to use in Cloudflare sitting.
Now with DNS cloud is Gray ==> the performance is better than before and there are no errors !!


#6

When the DNS is set to :grey:, your traffic is not going through Cloudflare, it is only using their DNS.

If you want to use Cloudflare services, you should set it to :orange: and set the SSL mode to Full (strict) [not flexible].


closed #7

This topic was automatically closed after 30 days. New replies are no longer allowed.