Wordpress website Rss feed is blank

Hello

On my wordpress website kim-tetzlaff.dk the RSS Feed is blank, but only if Cloudflare is activated. the strange thing is that I can read the RSS feed when I’m logged in to my website, which made me think that it might have something to do with cache. But it is only when cloudflare is active that you cannot read the RSS feed from outside and not logged in

I/People can only read the Rss feed if one of following conditions are met:

  1. Cloudflare is deactivated
  2. I’m Logged in on my website

Cloudflare is deactivated right now because that is the only thing that works.

Thanks in advance :slight_smile:
Kim Tetzlaff

Hi,

What’s your Cloudflare cache configuration? Do you use

a) Page Rule with Cache Everything?
b) APO for WordPress?
c) Cache Rules?

BTW, your embedded rel link to the feed is pointing to /feed/, which redirects to /feed

2 Likes

Thanks for your answer.

No page rule with Cache everything, I have tried both with APO active and not active, no difference. I have also tried to bypass caching when feed is in the url. Nothing works.

The feed url is correct:

1 Like

Could this be a compression issue at your origin?

When I run:

 curl -H "Accept-Encoding: gzip" https://kim-tetzlaff.dk/feed

I get an empty body returned. Same command with -I results in 200/304 status code.

But:

 curl -H "Accept-Encoding: br" https://kim-tetzlaff.dk/feed

will return the feed.

So perhaps Cloudflare passes on the blank page expecting it to be the real thing, as the HTTP status is 200 or 304 (revalidated).

2 Likes