Wordpress Visual Editor not working

Since changing to Cloudflare, my visual editor stopped showing up. Some people in the online problems were solve this problem by two methods:

  1. ‘page rule’ at Cloudflare which told the cache to ignore the wp-admin URL:
    /wp-admin/*
    [Cache Level] [Ignore Query String]
  2. 1st CloudFlare Flexible SSL
    2nd SSL Insecure Content Fixer

Regarding method 2, can i install CloudFlare Flexible SSL, if my site traffic is already going through Cloudflare?
Regarding method 1, i don’t know how to add page rules. Where can i find more info for a complete newbie?

You shouldn’t be using Flexible SSL. Your host should have an SSL certificate for your domain on their server.

Try using your browser’s Dev Tools (F12 in Chrome) and check the Console and Network tabs for errors.

I don’t think that Page Rule to “Ignore Query String” is going to help, as that’s a minor tweak of caching settings. But you’re welcome to try adding a Page Rule in the Cloudflare Dashboard:

Match *example.com/wp-admin/* and add setting for “Cache Level: Ignore Query String”.

1 Like

This sounds silly, but what browsers? Have you tried private windows? Do you have ad/tracker blocker plugins installed? Are you using Brave Browser?

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.