WordPress: "Updating failed. Error message: The response is not a valid JSON response."

After I enabled Flexible SSL, I can’t update any posts on my WordPress website.
I have Clourflare WP plugin installed on my site with “Automatic HTTPS Rewrites” and “Always Use HTTPS” - ON. I was trying various ON/OFF combinations of these settings, but I didn’t succeed anything.

The SSL site itself loads fine, until I don’t try to edit anything.

If I disable SSL then I can edit my content again.

Any thoughts which other settings I need to turn ON/OFF ?

I am using WP 5.3

1 Like

I also have the same problem

We tried to solve this issue with Cloudflare support, but unfortunately WP doesn’t work with Flexible SSL.
It loads mixed content (http and https) when you try to edit any content on your site.

You can make it work by switching OFF “Always Use HTTPS”. But it such case both versions of your site (http and https) are accessible. That means your have duplicate content and it is very bad from SEO perspective.

So there are two options:

  1. Totally turn OFF SSL mode
  2. Switch to FULL or FULL (strict) mode. This means you need to do some work on your hosting.

In my case I can’t do any required changes on my hosting, so I just turned OFF Cloudflare SSL.

This topic was automatically closed after 30 days. New replies are no longer allowed.