WordPress Update Functions.php

php

#1

I cant update my functions.php anymore…


#2

I use an SFTP program to edit it. What are you trying?


#3

I can use FileZilla, but i would love to use the normal editor in WordPress self for quick updates, but since i installed Cloudflare i would not safe anymore, do you have any idea if cloudflare blocks php functions?


#4

Cloudflare definitely doesn’t block PHP, but the firewall might block suspicious PHP functions. Your best bet would be to whitelist your IP address on the Firewall page IP Access Rule section.


#5

The software i use to manage all my website uses diffrent IPs so thats not the best option for me here… sad enough… is there a way to turn off firewall?


#6

I disabled security on that file in pagerules, everything is working now!


#7

Out of curiosity, which page rules were you using?


#8

If you want to update the WordPress functions.php in your child-theme with the WordPress editor you need te set a page rule in Cloudflare.

If domainname matches: https://domain.com/wp-content/themes/your-theme-child/functions.php
Then the settings are: Disable Security


#9

How long did it take before you were able to update functions.php? I have exactly the same problem. I’ve tried adding the rule as you specified above, but it hasn’t made any difference. I could just be impatient - it’s only been 5 minutes!


#10

It worked as soon as i pressed save… maybe you use admin cache as well? Maybe clearing the cache would solve the problem?


closed #11

This topic was automatically closed after 31 days. New replies are no longer allowed.