Wordpress site not working after SSL installed


My site is made on wordpress
Domain: cvmatch.com
Domain provider: GoDaddy
Host: Digital ocean

I have installed an SSL certificate from Cloudflare, and currently using the flexible version of the certificate.

Everyone else can access my site, however when i visit the website from my WIFI it is showing me the following error: ERR_CONNECTION_REFUSED. If access my website from 3G/4G from my phone it works fine, or anyone else accessing the site there is no problem even with Wifi.

However as soon as im connected to WIFI and try to visit the site the page doesnt load.

What do you guys think the problem is here, and why do you think this is happening?

P.S When setting up SSL i did manually change the URL structure on wordpress from http:// to https:// which originally caused the issue. However, it still doesnt explain why i can access the site on 3g/4g and not my wifi, and why others can still access the site as normal?

Kind regards,

Perhaps clear browser cache? Loads fine with ssl in place for me. Does it work on incognito mode on wifi?

I have tried this, and tried on incognito mode. No luck :frowning:

The strange thing is if a change my DNS server names to on the device, it works fine. It seems that my default IP/ DNS of my ISP is blocking it… but the issue here is thats a temp solution, and anyone accessing my wifi on their device has same issue when visiting the website.

Hi @user1637, ugh, that is a frown. (I am going to leave a couple of links at the bottom of this reply, I think don’t they’ll help you immediately, just good background on cloudflare & wordpress)

I found a couple of similar issues, but with no definite resolution indicated. Diagnosis was a cached DNS record and solution was to wait. The tickets did not indicate if that cache was on an intermediate proxy or local. Will keep digging.

Here are those background links I mentioned I’d share:

1 Like

Thanks! Hope we can find a solution to this strange problem.

What device are you using for testing? Do other devices on the same WiFi network have this problem?

Macbook Pro (tried both safari and chrome)
Iphone XS max (safari)
Samsung galaxy note 10 (default browser)

Yes all devices that are connected to my home WIFI have the same problem when trying to visit the website. I did contact my ISP but they seem to be as clueless as me :confused:

Cool…MacBook Pro. So you’ve got the Terminal App. Try some commands and post the results:

> host cvmatch.com

> curl -I https://cvmatch.com

The host command will show us the IP address it’s connecting to. The curl command makes an HTTP connection.

EDIT: Also, on the MacBook, use Chrome and open Dev Tools (F12 might do it), or Cmd-Opt-I (capital i). And its Security, Console, and Network tabs as you load the site. Network will show the connection headers and response. Security and Console show some quick results for the activity.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.