Wordpress REST API

Hello everyone,

I’ve been using a REST API to query another platform for customer details from my WooCommerce store to generate invoices. This allowed me to create an invoice for an order with a single click. However, after installing Cloudflare, I can’t see the orders on the platform where I issue the invoices. It seems Cloudflare is blocking it somehow. When I pause the service I got from Cloudflare, I can see the orders on the other platform again.

Does anyone know how I can resolve this issue without having to pause Cloudflare?

Hi,

Check this answer to a related topic for ways to investigate which feature of Cloudflare may be blocking your requests to the REST API endpoints, and how to adjust it:

1 Like

I have encountered an issue with Cloudflare blocking requests to my website. Specifically, the requests to the following URL: https://soapandbeauty.com/wp-json/wc/v3/orders?status=processing&per_page=************ from the IP address 37.77.7.*** are being blocked.

I have tried to resolve this by creating a rule in the IP Access Rules page with the ‘Allow’ action for this IP address. However, it didn’t work. This is causing problems as the billing company I work with cannot retrieve orders from my website.

I would appreciate any assistance or suggestions on how to resolve this issue.

A next step would be to identify which Cloudflare service is blocking the requests.

1 Like

i think free user dont see ip adress and details.

Not true. Even on a Free Plan, you’d see events logged IF the block was actually being performed by Cloudflare on that zone. No events = Cloudflare didn’t block or challenge.

Have you (or your website host) restored original visitor’s IPs after you added your domain to Cloudflare? If not, your origin may be rate-limiting Cloudflare IPs, blocking requests when they are proxied by Cloudflare.

The information you provided is quite technical for me. However, I’d like to mention that I identified an IP address that shouldn’t be blocked. I detected this address by disabling Cloudflare and using the Wordfence plugin. Now, what should I do on Cloudflare to allow all requests coming from this IP address?

Thank you for your assistance.

Cloudflare isn’t bocking, as established above by the fact that there are no logged events.

Ask your hosting provider for support.

Also, have you visited your site with Dev Tools open, as suggested by the linked answer above? What was the status code for the request that is not going through?

When I activate the “Pause Cloudflare on this site” option in Cloudflare, the integration site I use for invoicing receives the data without any issues. However, when I reactivate Cloudflare, the data doesn’t get sent to the invoicing integration site. My website itself works fine in both scenarios. It seems that the issue arises with the data transmission to the integration site when Cloudflare is active.

I’ve already reached out to my hosting provider, and they too believe this might be related to Cloudflare. I also visited the site with Dev Tools as you suggested.


`

So…

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.