Wordpress "redirected too many times" problem but only homepage url

hello everyone i recently migrated my website from one host to another host (ionos to Plesk VPS), using all in one migration plugin website migrated successfully but the website homepage URL shows “too many redirect” the problem is the only homepage url is not working specficaly but all my website pages, url, posts and WordPress dashboard loading correctly.

I am using Cloudflare for DNS & SSL, elementor, woocommerce etc in my website, When I shift my website back to old IP (host), the website works but in new host website homepage url not working.

the website only works when i disable the Cloudflare proxy so that means the problem is coming from the Cloudflare

fix i try:

Changing the site url
Changing Cloudflare SSL mode to full, flexible, and full strict
creating a default htaccess file
i try to open the website in incognito mode and another device
disabling the plugins etc (but nothing is working for me)

If anyone can help me with this it would be greatly appreciated

Greetings,

Thank you for asking.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Otherwise, have you tried to login to phpMyAdmin and check the SITE_URL and HOME_URL?, should be https://domain.com/.

Otherwise, might be something with the webs erver configuration file like .htaccess if there is some HTTP(S) redirection defined.

I’d suggest you to whitelist your old and new origin host / server / hosting IP address by navigating to the Security → WAF → Tools → IP Access Rules with the action “allow” for your Website and try again.

Could you check what option have you got selected for Browser Cache TTL when you navigate to the Cloudflare dashboard → Caching → Configuration? :thinking:

I’d suggest you to see the recommendations from the article below and implement them, due to usage of Elementor and Cloudflare:

Furthermore, may I ask if you are using some custom-made Page Rules? :thinking:

Before moving to Cloudflare, was your Website working over HTTPS connection?

Was WordPress configured to work over HTTPS?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS without any error
  4. Check with your hosting provider / cPanel AutoSSL / Let’s Encrypt / Certbot / ACME and renew it in case if needed
  5. Only then, when your website responds over HTTPS, you should un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Otherwise, I’d suggest as follows:

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding SSL settings at the SSL/TLS tab on Cloudflare dashboard:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.