WordPress: Post-processing of the image failed

Hi all, I have checked and there are similar postings on this issue but no resolutions yet.

I am now bypassing CF temporarily and the issue doesn’t occur.

After trouble-shooting with our hoster, we suspect that this is something on CloudFlare’s end. It looks like a possible overzealous rule with their WAF which is only available in the Pro plan or it could be some other settings.

Anyone has managed to figure this out with CF? Thanks!

I’m not sure what the issue is exactly, could you send an example of the issue and a reproduction URL?

I doubt this is an Cloudflare WAF issue, as I run multile WordPress sites, also few on a Pro plan (uploading images larger than 1200px, but smaller than 1.5MB in size), but it could be somehow.

If so, do you see any blocked event in your Firewall Events tab at Cloudflare dashboard by some rule?

Are you using the latest version of the official Cloudflare plugin for WordPress?

Does your hosting provider have ModSecurity enabled?

Furthermore, kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Also, do you see Cloudflare IP or visitor IP in your access/error log files at the origin host / server?

Does anything appear in your server access / error log, or maybe have you tried to turn on WordPress Debugging?

Therefore, may I ask how big/large the image you are trying to upload is (filesize and resolution) to your WordPress website proxied :orange: by Cloudflare?

Have you tried whitelisting/allowing your server IP in Firewall Rules and IP Access Rules at Cloudflare dashboard?

Which WordPress version are you running?
Which PHP version?

Furthermore, if recently updated PHP, it could be due to imagick package (for linux + PHP extension) as it has had some bugs two days in a row as far as I remember.


Kindly, re-check with your hosting provider / or cPanel if available to you if all the needed PHP modules/extensions are enabled.

Also, if PHP settings are set to the right one, like values of:

  • memory_limit (256M)
  • max_execution_time (300)
  • max_input_time (1000)
  • max_input_vars (5000 or 7000)
  • post_max_size (16M)
  • upload_max_filesize (16M)

Post-processing of the image failed likely because the server is busy or does not have enough resources. Uploading a smaller image may help. Suggested maximum size is 2500 pixels.

A bit helpful articles:

Thanks @fritex for your detailed suggestions.

I have tried almost everything you mentioned with our hoster and the issue still persists. In fact, this happens in 3 of our WP sites with different themes etc. since last Friday.

I have disabled all the WP plugins too, it is very likely due to CF based on what we have gathered so far.

What I can do now is to bypass CF for now and hopefully this issue will be resolved not too long from now.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.