[Wordpress] Plugin newsletter Mailpoet doesn't work

wordpress

#1

Hi,

Since i have start with cloudflare i can’t send newsletter with the plugin Mailpoet (wordpress).

I have this message error :

cURL error 35: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure
The WP scheduler doesn’t seem to be running correctly for Newsletter

I have contact the support of the plugin mailpoet who tell me that the problem if with server cloudflare or ovh

Have you any idea ?
Thanks


#2

My guess, you specified as host for outgoing email an address that you are now proxying through Cloudflare. That wont work. Either unproxy that address in Cloudflare (be aware this will leak that address though) or change the host in your plugin configuration to point to the proper, unproxied, address.


#3

On the configuration of plugin i put my email gmail for that, I tried putting my email ovh too and it does not work either.


#4

I am not talking about the email address but the hostname which you use to send the email. This is an assumption, I am not familiar with that piece of software, it might be best to contact the original developer for that, respectively refer to your sysadmin.


#5

I have contact the developer of plugin newsletter and he tell me this :

The error could be down to an old version of OpenSSL on your server which may not support TLS, as I see it’s trying to use SSL V3.

But what i do make to repair it ?


#6

Thats somewhat beyond the scope of this forum and you’d better discuss this with your sysadmin. However, considering you started having the issue after the DNS migration, I’d rather tend to believe it is an issue of a proxied mail server than - suddenly - a library versioning issue.


#7

Ok thanks for help.