Wordpress password reset url is not working

Hi,
Previously - when we were on godaddy wp password url used to work fine and it is currently not working - the urls is prefixed with http://url8008. Can it be that the cloudflare is now set up to only allow HTTPS traffic? how can wordpress be made to send the HTTPS urls? or we need to stop allowign only https traffic with the cloudflare?
Please help!
Dave

Was your site fully configured for HTTPS before you moved it to Cloudflare?

thanks for the reply man - yes it was on godaddy ssl - fully https - what would you suggest?

In your WordPress General Settings, is the URL set for HTTPS?

yes - just rechecked
it shows
https://

not sure why wordpress is sending http reset link -
please advise

Your best bet is to ask on a WordPress forum why it’s emailing the incorrect link.

yes but does cloudflare block http links?

No.

You probably have enabled some HTTPS redirects/rewrites in your SSL/TLS Edge Certificates settings.

thanks - I did not change anything there - all as default - new users cannot subscribe now and lost passwords cannot be reset,when urls in wp emails are clicked it says no server found…should I ask wordpress forum as well?

If it’s really using a “url8008” subdomain, then you need a DNS entry for that, but I’ve never seen WordPress use a subdomain for a password reset link. That sounds like a non-standard configuration.

And because it’s GoDaddy, they’re not going to show you what your DNS records really are because you’re using Cloudflare DNS.

I suggest you add a DNS “A” record for ‘url8008’ with the same IP address as your main site.

1 Like

yes - can it also be due to wp using sendgrid to send the emails? can this subdomain be used by them previously but not working now due to moving to cloudflare?

That’s certainly possible. But that’s why Cloudflare tells you to verify all your DNS records during the onboarding process. If that url8008 subdomain is missing, you’ll need to get that setting from Sendgrid (if that’s where it came from), or see if GoDaddy can dig it up for you.

2 Likes

thank you for your fantastic reply - yes sendgrid actually has this subdomain which was previously entered in godaddy - I did not know cloudflare has to have it re-entered in DNS settings…can you help - do such records need to be proxied or dns only?

For a Sendgrid record, it should be :grey: DNS Only.

I set this as DNS only and it started complaining about the invalidity of the ssl certificate - had to set it to proxied…there can be some danger in this? thank you for your support

Ah, as it’s only for HTTPS connections, :orange: Proxy may work.

1 Like

thanks a lot) working now)

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.