Wordpress on http on Cloudflare https

Wordpress advises, if you have an SSL certificate, change the 2 paths in the settings from http to https

but if I do this and disable Cloudflare, then I get circular redirects and the site is unavailable

can i leave the settings for wordpress - http?

or does it create a load, forcing Cloudflare to constantly redirect everything and everything to https?

what do you advise?

Meaning, you do not have a proper and valid SSL certificate installed at your host origin/server, and using the Cloudflare on Flexbile SSL instad of Full (Strict).

This is the one reason what happens as described on the article(s) below:

Kindly, if you already haven’t, check the below article how to propperly setup SSL with Cloudflare for your domain:

Therefore, if you have a valid SSL certificate and already installed it at your host origin/server for your domain, kindly switch the SSL options on the SSL/TLS tab to Full (Strict).

Available SSL options at Cloudflare are here:

If any other issues occur, follow the needed steps for troubleshooting from article below:

If you want to use Cloudflare SSL, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare CA Origin Certificate:

Even if you are using Flexible SSL, which is causing issues, you should switch the settings to HTTPS prefix.

Other things to check are the Always use HTTPS and Automatic HTTPS Redirection options, if they both or one of them is enabled for your domain at Cloudflare dashboard.

https://support.cloudflare.com/hc/en-us/articles/227227647-How-do-I-use-Automatic-HTTPS-Rewrites-

1 Like

no need to change anything, the Wordpress settings must be https, since the domain must have a permanent full gluing

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.