WordPress media and email issues

wordpress
email

#1

Hi all

I switched to CloudFlare a couple of weeks ago and everything seemed fine.

Recently I have noticed a couple of issues which I think may be related to the switch.

1 - emails coming in to our inbox seem lower than usual. I just CCed my colleague in on an email and it got bounced back. Her inbox is not full.

2 - when trying to upload media to WordPress two of my colleagues had repeated issues with the media not uploading. They both tried multiple times and eventually it worked. They both have stable, fast internet connections.

Is there anything I can check with my CloudFlare settings to solve this?

Thanks


#2

Hey there.

There’s a popular article about email here. The fact that you are only partly receiving email (or seem to be) is a bit odd though…

Were the uploads timing out or what was the specific error? It’s strongly advised to create a Page Rule for wp-admin to bypass cache, such as

*example.com/wp-admin/*
Cache Level: Bypass

Or something similar.

You can also toggle ‘Development Mode’ for your entire site while debugging these issues, which is detailed here


#3

Hi, thanks very much for the quick feedback.

Looking at my DNS settings I see:

MX - domain - mail handled by alt1.aspmx.l.google.com

and five other entries like that with the number going up by 1.

However there is neither an orange nor a grey cloud for each, it is just empty. Is this an issue? If so, how can I solve it?

I did not see a record for:

“A - mail - points to 1.2.3.4”

Should that be added?

I will look into creating a Page Rule too.

Thanks


#4

Hi, no problem.

No that is normal for MX records. Cloudflare only proxies HTTP/HTTPS traffic so there is no grey/orange cloud for those records. I’m not sure what your email setup is like but it looks like it’s Google something. I found this article outlining a setup process, which appears to omit the A ‘mail’ record entirely. I’m not sure if you’ve followed these steps already but it seems like a fairly straightforward process.


#5

thanks.

Yes, the google mail setup is already done exactly as the link describes


#6

Do you have an MX record for ASPMX.L.GOOGLE.COM ? They say that is the most important one… Sorry, I don’t have any experience with GSuite so I’m grasping a bit. Have you tried this interactive troubleshooty thing?


#7

yes, I have that one.

thanks for the link. I ran it and got a critical error!

SPF must allow Google servers to send mail on behalf of domain.
Decision domain owner discourages use of this host
Record v=spf1 +a +mx +ip4:69.175.46.98 +include:relay.mailchannels.net +ip4:208.94.37.4 +include:spf.mandrillapp.com ~all

DKIM is not set up.

DMARC is not set up.

Can you offer any guidance on this please? Things are getting a bit too technical for me now :slight_smile:


#8

That’s ok, we’re both learning about GSuite together :rofl:

So it looks like you need to add an SPF record with that string in it, as outlined here

After you do that you need to set up DKIM, which we can read about here.

Once that is done you can set up DMARC by following these instructions.