WordPress Login Problems

I have just created a Cloudflare account, and changed the Domain to point to the Cloudflare servers as instructed.

After a very short time the site became available as (https:)
However I had two significant problems.

  1. I was unable to make any edits in WordPress. I have tried editing an existing post, and it fails reporting: “Publishing failed. You are probably offline.”
  2. None of the images on the site are displaying, including the header.
    I have tried using a global search and replace http… to https… (Velvet Blues plugin on images only) but that didn’t work.

I then edited the Wordpress general settings to https:
The site is viewing fine, however I am now locked out and can’t log into WordPress.
Whilst this is probably a WordPress rather than Cloudflare issue, can anyone help?

Update: I have gone into the SQL tables and put the General URL’s back to http://, this means I can again access the WP dashboard, but still unable to make site edits.
I have looked at the Cloudflare tutorial on images not appearing - Rocket is disabled as suggested, and I don’t have Mirage.

Are you using the Flexible SSL mode in Cloudflare? If so, it should be Full (strict).

Thank you for the reply, I was feeling a bit isolated! I am currently using Flexible, however I have resolved the issue - it was due to the fact that I had not installed the Cloudflare Plugin. Having how done that and linked credentials with the Cloudflare API, everything is working OK. I will experiment with some of the other recommended settings a little later.
I must say, that Cloudflare could do with a tutorial on setting up with a Wordpress installation - I got the answer from WPASTRA How To Use Cloudflare With WordPress – Complete Guide to CDNs.

You should be aware that Flexible is just faking HTTPS and does not actually encrypt requests to your server. That is also why it causes problems, especially with Wordpress.

You should always use Full (strict) for that reason.


I tried the Full(strict) setting and it caused a certificate error. I then used the SSL/TLS Recommender, and it emailed me advising to use Full - I have done that and it seems to work fine.

Full is exactly as unsafe as Flexible. Only Full (strict) provides secure connections.

The certificate error is solved by installing a certificate on your server, for example a Cloudflare Origin certificate.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.