Wordpress LiteSpeed Cache issue?

Answer these questions to help the Community help you with Security questions.

What is the domain name?
drytopps DOT com

Have you searched for an answer?

Please share your search results url:

When you tested your domain using the [Cloudflare Diagnostic Center](Cloudflare DOT com/diagnostic-center/), what were the results?
I saw no utility to test the domain on that link.

Describe the issue you are having:
I’ve setup Cloudflare on over 30+ sites with no issues. But on Drytopps DOT com, I got the blank page with:

[This site can’t provide a secure connection

What error message or number are you receiving?

What steps have you taken to resolve the issue?

  1. I checked the SSL certificate on the WHM server panel and it is active

  2. I tested the SSL certificate on SSLLABS DOT COM and it returns an A+ rating with no issue.
    This site works only in browsers with SNI support.
    This server supports TLS 1.3.
    HTTP Strict Transport Security (HSTS) with long duration deployed on this server

    I tested the SSL certificate on SSL Shopper and it is green checkmarks on everything.

drytopps DOT com resolves to

Server Type: Cloudflare

The certificate should be trusted by all major web browsers (all the correct intermediate certificates are installed).

The certificate will expire in 89 days. [Remind me](sslshopper DOT com)

The hostname (drytopps DOT com) is correctly listed in the certificate.

  1. I do have the SSL setting on Full (Strict)
  2. I did some testing with plugins and have disabled the LiteSpeed Cache plugin. Not sure why but this could be the issue.

Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

  1. Nothing except for the diagnostics to try and isolate the issue

Have you tried from another browser and/or incognito mode?

Please attach a screenshot of the error:

To follow up: It appears the website is working properly now with LiteSpeed Cache plugin deactivated. Any ideas on why this plugin might have caused this issue?

Your domain is loading absolutely fine over SSL for me here and anywhere else I have tried.

Can you reproduce the ERR_SSL_VERSION_OR_CIPHER_MISMATCH on more than one device?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.