Wordpress installed but going to a default error page with SSL on

I enabled Cloudflare via the back end of cPanel. It shows active in my account. I have it set to flexible. I also tried full. I had it set to always use HTTPS and then I also tried not but either way my Wordpress installation is showing a default error page:

https://www.rebelflair.com/cgi-sys/defaultwebpage.cgi

Because I set this up with cPanel I did not change the name servers myself as usual.

It’s a secure error page but what am I doing wrong? I have Cloudflare active on two other domains with no issues though that is on other hosting.

That essentially disabled SSL. Set it back to “Full strict” and make sure your server is configured for HTTPS and has a valid certificate. This is most likely the reason for the error you experienced, your host didnt configure the server for HTTPS.

Okay great, thank you. I have contacted them.

Thanks, all is working now. SSL was on but the name servers had not fully propagated yet

Seems, the issue got fixed :slight_smile: