Wordpress images not showing after adding cloudflare

I can’t figure out why some of my images do not load at all, before enabling cloudflare everything was good, now even elementor and customize page setting stopped working. Could anyone take a look and point me into the right direction?
https://cscafe.xyz/faq

May I ask if you have had an SSL certificate already installed at your website before you moved to Cloudflare?

Moreover, due to an SSL, what kind of SSL option have you got enabled at Cloudflare dashboard for your domain? (Flexible, Full …)

Also to note here, maybe it could be due to some mixed contet in between?

What error do you get for your images? 404 error or some other?

Regarding Elementor, is it the plugin for WordPress or something else?

If so, kindly check here how to setup Cloudflare to make suer it works with Elementor because it could either be some Minification option enabled, or Cache options, or even Firewall and Security options enabled, which potentionally could block some script of loading, etc.

Or, it could be a Rocket Loader issue?. If so, try disabling Rocket Loader under “Speed → Optimization” at Cloudflare dashboard first.

Here is an article for a Page rules:

There are know issues already here, so try to find out if that one could be related to some of:

Yes, I had one issued by my webhost, and I have my SSL option on Cloudflare set to flexible.
I don’t see any error on the website itself, might have to check the console, and yes elementor is a wordpress plugin.
Rocket Loader is disabled. I will look over on the Cache options

Dont do that please … its the worst you can do in Web.

Let me explain Flexible to you:
Data get send half way encrypted but half way unencrypted … so its useless.
In my opinion people should get sued for using it! And CloudFlare for providing it and not telling/stating anyone what SSL-Mode this Site is using, so Browsers could warn users not to type in sensible infosmations at sites which run with SSL-Mode Flexible! But its not possible and completely intransparent for users… so your CC infos may already be used somewhere else.

So many WordPress sites use Flexible and do sell things. Now when it comes to selling things you always transfer sensible informations and CreditCard Infos … well these infos half way are getting send in PLAIN TEXT. It is again all GDPRs, specially the german one which is pretty strict.
But these are just my two cents…

.

Your pictures are not loading because your links are not set to HTTPS.

Th URLs of all of these 3 files begin with HTTP, not HTTPS.

So after installing your SSL Cert you also should rename all HTTP links to HTTPS.
You can do so by using the Plugin “Better search and replace” for WordPress as you are using WordPress.
I will quickly quote myself:

2 Likes

actually it was simpler than that. I just enabled Full strict and everything is working again, even elementor. thank u so much!!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.