WordPress Image Upload Error Post-Processing of the Image Failed

Post-processing of the image failed likely because the server is busy or does not have enough resources. Uploading a smaller image may help. Suggested maximum size is 2500 pixels.

I allready researched the Web for 8 hours, is this a problem becasue of Cloudflare Pro, i have bought it that last days since then it doesn’t work at all before that only sometimes this happened and sometimes i was able to upload images?

May I ask which WordPress version are you running?
Are you having some plugin for media files installed too?
What PHP version are you running?

Kindly, check here:

After WordPress 5.3 there is some new feature of “scaling” the images:

I am afraid this is not related to Cloudflare.

My Php Version is 7.4 and Wordpress Version is: 5.7.2

So im not sure what to do now, i have connected Cloudflare with Nitropack btw. configured it like the tutorial from Nitropack said.

All my Plugins:

active-plugins-status": {
“Animentor \u2013 Lottie & Bodymovin widget for Elementor”: “1.1.1”,
“Antispam Bee”: “2.9.4”,
“Better Search Replace”: “1.3.4”,
“Blocksy Companion (Premium)”: “1.8.6.4”,
“Cloudflare”: “4.5.1”,
“Creative Mail by Constant Contact”: “1.4.0”,
“Disable “BIG image” Threshold”: “1.0”,
“Elementor”: “3.2.5”,
“Elementor Pro”: “3.3.1”,
“eRecht24 Safe Sharing”: “2.0.21”,
“Google Analytics for WordPress by MonsterInsights”: “7.17.0”,
“iThemes Security Pro”: “7.0.1”,
“NitroPack”: “1.5.4”,
“RumbleTalk Chat”: “5.7.8”,
“Site Kit by Google”: “1.35.0”,
“Smash Balloon Instagram Feed”: “2.9.1”,
“Under Construction”: “3.88”,
“UpdraftPlus - Backup/Restore”: “2.16.58.25”,
“WPForms Lite”: “1.6.7.3”,
“WP Mail SMTP”: “2.9.0”

I just uploaded 2 images thought it works and then then error came again, its so frustrating

Regarding the plugins, I haven’t used enough of them so I cannot tell.

What happens if you temporarly Pause Cloudflare for your Website, or turn the :orange: to :grey: cloud, clear/flush/purge the cache and re-try uplading an image?

  • if the same error, than it’s the origin host/server, not Cloudflare …

I doubt, because I have had some and still have few Pro plans running WordPress websites. No problem at all.

Kindly, try deactivating all of them.
Then try to upload.
Does anything changes?
If yes, try enabling one by one and in between each being enabled, try to upload the same or other image again, until you get the error back.

Otherwise, re-check for your web/disk space available.

Nevertheless, maybe out of the scope for this forums but, can you check and write back, if the PHP modules are installed and active:

gd
igbinary
imagick

And the values for PHP settings:

max_execution_time = 300 (if possible or 120)
max_input_time = 1000 (if possible)
memory_limit = 256M (if possible)
post_max_size = 32M (if possible)
upload_max_filesize = 32M (if possible)

I contacted my Hoster, and they made this with the PHP Memory Limit. Unfortunately, it didn’t change anything, what will happen when I turn off the Cloudflare Plugin since I’m connected to their server, won’t my website gett offline or crashed? I’m sure I have read something about this so I’m not sure what to do right now, hope someone can help me.

Edit: Now it works fine, im able to upload images, but for how long i don’t wanna paly this game day in day out so if it happens again, I will update this post again.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.