Wordpress homepage cache issue, new posts are not displayed

Hi, I’ve been searching in this forum and it seems the only solution of this problem is due to the hosting has its own internal caching system. In my case, my hosting doesn’t have any. I notice I can see new posts when I’m logged in. But when I use different browser, I can only see old posts. I have set my caching level as standard, I also set rules for my wordpress index : *domain.com/index.php cache level bypass.

the only wordpress cache plugin I use is WP Cloudflare Super Page Cache. can anyone help me?

Hello,

you could try to flush the Cloudflare cash for your site. This can be be done in the dashboard of your zone. Look here for more details Purging cached resources from Cloudflare – Cloudflare Help Center

If this won’t work it would be helpful if you provide a link to your website.

You’ve probably configured “Cache Everything” as part of that plugin’s setup, so it’ll be up to that plugin to properly purge the homepage. Have you asked for support in that plugin’s support forum?

1 Like

Hi Markus, I did that too, nothing happens. My website is tuvie.com, the latest post title should be “Fabita Cucinotta Mini Kitchen…” yet the latest post from my homepage still an old post “x1 basketball shoe…”

@sdayman, ok let me check the plugin, it’s very slow since I’m having intermitten error 520 as well, but for this issue I will create another thread.

Oh…you’re running Ezoic, aren’t you? In that case, all bets are off. They have their own custom configuration that makes it very difficult to override within Cloudflare. Running additional caching makes it even more difficult to track down.

I suggest you disable the WP Cloudflare Super Page Cache plugin for now.

@sdayman oh, yes, I integrate my cloudfare with ezoic, wait let me disable my caching plugin.

@sdayman so what does it mean? that this is not cloudflare issue but I have to ask ezoic?

It sounds like your may be running three caches: Server, WP Cloudflare Super Page Cache, and Ezoic. And now there’s a problem. So disable as much caching as you can, then see if things get better.

@sdayman if that’s the case, I have removed the cache plugin, and currently asking ezoic support about this problem.

Also make sure you don’t have any Page Rules here that set caching.

@sdayman so I just set page rule as tuvie.com/ Cache Level: Bypass. What about caching level? there’s no option to “no cache”, only “No query string”, “Ignore query string”, and “standard”.

Please don’t add any caching page rules while you troubleshoot this.

ok, i deleted the previous caching bypass rule.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.