Wordpress Gutenberg Editor Post Not Updating


#1

Hi Cloudflare. I purchased your pro account last week and i am having an issue as I cannot save my posts on wordpress Gutenberg editor which is my editor of choice. “so do not want to go back to classic editor”. I have disabled the x2 to rules on the wordpress firewall as you stated in the pop up 25A,25B . I have also disabled rocket loader as that was not showing my Amazon Native ads.
The only way I can edit my site is to pause cloudflare then edit my work.

can you let me know if there is a way round this please. As i have wanted cloudflare for ages and do not want to get rid of my subscription.

many thanks adam


#2

Maybe related to

though you stated you disabled WAF rules WP0025A/WP0025B

some others https://github.com/WordPress/gutenberg/search?o=desc&q=cloudflare&s=updated&type=Issues


#3

I’ve done the 25A/25B thing and that helped me with Gutenberg.

Try going to Cloudflare Firewall settings and add your home IP address as a Whitelist.


#4

:wave: @probarber,

The Gutenberg editor is still in beta is it not? https://wordpress.org/plugins/browse/beta/ It is unfortunate that the editor reuses existing WP endpoints, but guess that makes sense since at the moment it is a bolt on to pre-5.0 versions of WP and new end points don’t exist.

What WAF rule is now being triggered when you attempt to post?

Getting rid of a Cloudflare subscription to support beta software is certainly one possible approach to solving the issue. But it appears Cloudflare has been working with the Gutenberg team on supporting the plugin, if you have a new issue you might want to file a bug with the Gutenberg project or open a support ticket with additional log data. https://github.com/WordPress/gutenberg/issues/2704

-OG


#5

Hi thank you very much for your reply I get “100030ARGS_STRICT Challenge” Rule
when I try and update my post I get

Updating failed
Cloudflare is blocking REST API requests

Cheers


#6

:wave: @probarber,

When you disable that WAF rule does the post submission succeed?

-OG


#7

Hi Guys thanks for your replies, as a conclusion I disabled x3 100030ARGS rules and also whitelisted my home IP address which has resolved the matter and Gutenberg is now autosaving posts as it should. Awesome