WordPress, error 1101 but no workers

We started getting Cloudflare 1101 Worker errors for some links to our Wordpress web site. That’s strange because we have NO workers setup (confirmed in the CF dashboard pages.

Managed to narrow the problem down to urls with an incorrect Google Analytics parameter.

For example Easy charts and summaries in Excel - Office Watch worked OK.

but this (sent in error) Easy charts and summaries in Excel - Office Watch generated the 1101 error.

We fixed the problem by turning OFF the WordPress Automatic Platform Optimizatiom - leaving standard CF caching on. The %%list.name%% urls now show up correctly.

Presumably APO adds a Google Analytics worker which doesn’t show up in the workers list?

We’d prefer to use APO … is there any way to fix this? It seems like a CF bug since the url should not generate an error, just show the target page without logging to Google Analytics.

Thanks,

Open a ticket and post the ticket number here. @yevgen usually checks on these types of issues.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

Thanks for your advice.

Ticket 2083371 now posted.
The first CF support response was some kind of reflex response that’s not relevant to the problem described. Looks like a stock reply from someone who half-read the ticket. Asked for escalation

1 Like

@sdayman I see what you meant about “an automatic response that does not help you”.

The CF Support guy doesn’t appear to understand or care about the problem. Lot’s of irrelevant talk about the CF plugin and APO but nothing relevant to the 1101 error.

A request for escalation was ignored … so I’m back here hoping for either an answer or someone at Cloudflare to pay attention.

Grrrrrr

Hi,
Have you tried to Purge Everything from your Cloudflare cache from the Caching Tab on your Cloudflare dashboard, then wait approximately 1 minute and visit your page using Incognito Mode/Private Browsing Mode (so we can control for browser cache), and see if the error persists?

Jeff,

Yes – we tried Purging and other options before, by process of elimination, finding a workaround. All our tests are in Incognito mode.

Just a few moments ago we tried again. No change.
Turned on APO, Purged the Cache and waited. Then tried the link, the same error was generated for the unusual but valid URL.

Error 1101 Ray ID: 61ef9ec71c1bfa2c • 2021-02-09 18:23:12 UTC

Worker threw exception


After the test we turned APO off and immediately the above link worked properly. The web page was displayed.

I understand plenty of customers report problems that are fixable by changing settings etc … this is NOT one of those. It seems to us like a clearly replicatable bug where CloudFlare’s APO is triggering an error for a valid web page.

Thanks,

Hi Peter,
I tried looking up that Ray ID but no success as Cloudflare only keeps a sample of the data for your site at this plan level.
Although you’ve tried nearly everything already, would you be able to remove the Cloudflare Wordpress plugin and then reinstall? This has worked for a couple customers in the past.

I might try that during some downtime. But frankly it sounds like a ‘shot in the dark’.

Appreciate your time and I’ll report back. Fingers crossed.

After too much trouble with CloudFlare Support it was reluctantly confirmed byCloudflare as a bug. It’s said to have been logged as an issue to be fixed, probably in the WordPress APO by CloudFlare.

The problem was the presence of %%list.name%% in the url parameters. That’s not strictly correct and causes an IO or validation error if strictly parsed.

Despite that problem, the page still works because few, if any, sites parse that strictly. Most web sites tolerate errors like that and display the page. It doesn’t break Google Analytics, which the parameter was intended for.

It’s only when CloudFlare’s APO tries to process the malformed URL that the Error 1101 is generated. Instead of ignoring the issue and passing it through to the site.

Thanks to @jeffrc @sdayman for your help and suggestions.

1 Like

Shoot…if only I’d hovered over those links. It sounds like this:

1 Like

Yeah – that seems like the same thing.

‘Incorrectly coded’ is right - it’s a mistake by someone making the URL … but it’s an error that should be tolerated by Cloudflare – just as the host site accepts it.

It’s a shame links are converted in these forums – it hides the important information.

Thanks for making that connection. I searched for %% not single %.

It’s very annoying to see this is a problem which has been known for over a year with no fix.

1 Like

We are sorry for not handling the error correctly. We will patch APO worker with a fix. Initially we had a fix that increased the bundle size of the script significantly, which caused increased error rate in some busy parts of Cloudflare network. We reverted the change and now need to address the issue differently.

1 Like

@yevgen thanks for the quick reply. It’s nice / relief to know someone is on the case.

1 Like

Hello,

Have you enabled the Under Attack Mode option?

No – but CloudFlare has confirmed it’s a bug in APO so we’ll leave it in their hands.

We’ve disabled APO for our sites and might try it again in the future. It’s not a high priority.

Thanks

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

The issue has been fixed, you can try to enable APO again.

3 Likes